2c2fcbd2e0
Manually merged: hack-5.4 230-openwrt_lzma_options.patch bcm27xx 950-0283-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch x86 011-tune_lzma_options.patch Remove upstreamed patches in collaboration with Ansuel Smith: ipq806x 093-1-v5.8-ipq806x-PCI-qcom-Add-missing-ipq806x-clocks-in-PCIe-driver.patch 093-2-v5.8-ipq806x-PCI-qcom-Change-duplicate-PCI-reset-to-phy-reset.patch 093-3-v5.8-ipq806x-PCI-qcom-Add-missing-reset-for-ipq806x.patch All other modifications made by update_kernel.sh Build-tested: bcm27xx/bcm2708, ipq806x, x86/64 Run-tested: ipq806x (R7800), x86/64 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> [update commit message/tested] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
72 lines
2.6 KiB
Diff
72 lines
2.6 KiB
Diff
From b3d00b452467f621317953d9e4c6f9ae8dcfd271 Mon Sep 17 00:00:00 2001
|
|
From: Imre Kaloz <kaloz@openwrt.org>
|
|
Date: Fri, 7 Jul 2017 17:06:55 +0200
|
|
Subject: use the openwrt lzma options for now
|
|
|
|
lede-commit: 548de949f392049420a6a1feeef118b30ab8ea8c
|
|
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|
---
|
|
lib/decompress.c | 1 +
|
|
scripts/Makefile.lib | 2 +-
|
|
usr/gen_initramfs_list.sh | 10 +++++-----
|
|
3 files changed, 7 insertions(+), 6 deletions(-)
|
|
|
|
--- a/lib/decompress.c
|
|
+++ b/lib/decompress.c
|
|
@@ -49,6 +49,7 @@ static const struct compress_format comp
|
|
{ {0x1f, 0x9e}, "gzip", gunzip },
|
|
{ {0x42, 0x5a}, "bzip2", bunzip2 },
|
|
{ {0x5d, 0x00}, "lzma", unlzma },
|
|
+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
|
|
{ {0xfd, 0x37}, "xz", unxz },
|
|
{ {0x89, 0x4c}, "lzo", unlzo },
|
|
{ {0x02, 0x21}, "lz4", unlz4 },
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -328,7 +328,7 @@ quiet_cmd_bzip2 = BZIP2 $@
|
|
# ---------------------------------------------------------------------------
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
- cmd_lzma = { cat $(real-prereqs) | $(LZMA) -9; $(size_append); } > $@
|
|
+ cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
|
|
|
|
quiet_cmd_lzo = LZO $@
|
|
cmd_lzo = { cat $(real-prereqs) | $(KLZOP) -9; $(size_append); } > $@
|
|
--- a/usr/gen_initramfs_list.sh
|
|
+++ b/usr/gen_initramfs_list.sh
|
|
@@ -229,7 +229,7 @@ cpio_list=
|
|
output="/dev/stdout"
|
|
output_file=""
|
|
is_cpio_compressed=
|
|
-compr="gzip -n -9 -f"
|
|
+compr="gzip -n -9 -f -"
|
|
|
|
arg="$1"
|
|
case "$arg" in
|
|
@@ -245,13 +245,13 @@ case "$arg" in
|
|
output=${cpio_list}
|
|
echo "$output_file" | grep -q "\.gz$" \
|
|
&& [ -x "`which gzip 2> /dev/null`" ] \
|
|
- && compr="gzip -n -9 -f"
|
|
+ && compr="gzip -n -9 -f -"
|
|
echo "$output_file" | grep -q "\.bz2$" \
|
|
&& [ -x "`which bzip2 2> /dev/null`" ] \
|
|
- && compr="bzip2 -9 -f"
|
|
+ && compr="bzip2 -9 -f -"
|
|
echo "$output_file" | grep -q "\.lzma$" \
|
|
&& [ -x "`which lzma 2> /dev/null`" ] \
|
|
- && compr="lzma -9 -f"
|
|
+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
|
|
echo "$output_file" | grep -q "\.xz$" \
|
|
&& [ -x "`which xz 2> /dev/null`" ] \
|
|
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
|
|
@@ -320,7 +320,7 @@ if [ ! -z ${output_file} ]; then
|
|
if [ "${is_cpio_compressed}" = "compressed" ]; then
|
|
cat ${cpio_tfile} > ${output_file}
|
|
else
|
|
- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
|
|
+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
|
|
|| (rm -f ${output_file} ; false)
|
|
fi
|
|
[ -z ${cpio_file} ] && rm ${cpio_tfile}
|